372 Membres en ligne
Apprenez à mettre en place des objectifs, le suivi ecommerce, vérifier l'exactitude des sources de trafic ou encore discuter des entonnoirs multicanaux, des objectifs, et le commerce électronique avancé
Guidez moi
star_border
Répondre

Google Analytics (pour Android) : Problème avec le CA généré par nos produits

Novice ✭

Bonjour,

 

Je rencontre un problème avec mes chiffres d'affaires sur Google Analytics. Les valeurs des inapps relevés dans le Play Store et celles renvoyés par Analytics sont complètement différentes. Lors de phases de test, nous n'avions pas décelé de problèmes particuliers. Cependant, après la mise en ligne de l'app, certains inapp posaient problèmes.

A titre d'exemple, un inapp (d'une valeur de 1.19$) nous a donné un CA de 300$ lors d'un achat. De plus, d'un jour à l'autre, le CA généré par cet inapp change (12$, 300$, etc). Certains inapps remontent avec les bonnes valeurs, mais se retrouvent mêlés aux fausses données.

 

Le code utilisé pour récupérer le produit et l'envoyer à GA est le suivant :

ProductAction productAction = new ProductAction(ProductAction.ACTION_PURCHASE)
                    .setTransactionId(transaction_id)
                    .setTransactionAffiliation("Google Play Store")
                    .setTransactionRevenue(product_price)
                    .setTransactionTax(0)
                    .setTransactionShipping(0);

            Product product = new Product()
                    .setId(product_id)
                    .setName(product_name)
                    .setCategory("In-App Purchase")
                    .setPrice(product_price)
                    .setQuantity(1);

            HitBuilders.ScreenViewBuilder builder = new HitBuilders.ScreenViewBuilder()
                    .addProduct(product)
                    .setProductAction(productAction);

            mGAtracker.send(builder.build());

Suite au problème, j'ai d'abord vérifié si le problème ne venait pas de nous et j'ai affiché sur le log les valeurs que l'on renvoyait à chaque inapp. Je n'ai jamais réussi à obtenir les valeurs suspectes que l'on reçoit sur GA.

 

De plus, j'ai effectué des achats sur un compte test afin de reproduire le problème, mais sans succès. Les valeurs remontées sont bien les bonnes lors de ma nouvelle session de test.

 

Je ne vois donc pas ce qui peut poser problème, et ce qui provoque des valeurs si disparates. En espérant qu'une solution (ou même une vague idée du problème) soit proposée, je vous souhaite à tous une excellente journée.

 

Merci d'avance à ceux qui auront pris le temps de m'aider (et ceux qui auront pris le temps de lire également Smiley heureux